Winaero Tweaker 0.15 is here with fixes and improvements

I am happy to announce a new version of my freeware app, Winaero Tweaker. Version 0.15 comes with a number of important fixes for users of Windows 10 version 1903, along with new features added for all supported Windows versions. 

Winaero Tweaker 015

Update

I've released version 0.15.1 here. It should fix the Startup Sound issue and the Compact OS removal procedure (see the comments). Thank you guys for your assistance!

Fixes for Windows 10 version 1903

Improvements and fixes for other Windows versions

  • When you disable/remove the Quick Access icon from the navigation pane of File Explorer, it should not break the drag-and-drop action for the left pane.Winaero Tweaker Navigation Pane Remove Quick Access
  • The "Keep Thumbnail Cache" feature now works for 32-bit apps running on a 64-bit Windows version.Winaero Tweaker Keep Thumbnail Cache
  • The 'Elevated Shortcut' feature should not suffer from being opened on high-DPI screens and render its contents correctly.Winaero Tweaker Elevated Shortcut

New Features

Traditionally, I would like to say BIG THANKS to each and every Winaero Tweaker user. Your support, reports and suggestions are always helpful.

Resources:
Download Winaero Tweaker | The list of Winaero Tweaker features | Winaero Tweaker FAQ

46 thoughts on “Winaero Tweaker 0.15 is here with fixes and improvements

  1. rens1o

    Thank you for good work. :)

    Reply
  2. Shyam Reddy

    Another great release with good number of features especially for 1903. Thanks Sergey! You are a star!

    Reply
  3. Dave

    I’m trying to replace the startup sound. Win 0 pro 1903 1832.175. It’s not working. My sound files are all located in c:\windows\media and they work when I set them through windows.

    See the end of this message for details on invoking
    just-in-time (JIT) debugging instead of this dialog box.

    ************** Exception Text **************
    System.IO.FileNotFoundException: Could not find file ‘C:\WINDOWS\SystemResources\imageres.dll.mun’.
    File name: ‘C:\WINDOWS\SystemResources\imageres.dll.mun’
    at System.IO.__Error.WinIOError(Int32 errorCode, String maybeFullPath)
    at System.IO.File.InternalCopy(String sourceFileName, String destFileName, Boolean overwrite, Boolean checkHost)
    at WinaeroTweaker.Pages.pageStartupSound.ReplaceWaveResource(String cNewWaveFile)
    at WinaeroTweaker.Pages.pageStartupSound.btnStartupSoundReplace_Click(Object sender, EventArgs e)
    at System.Windows.Forms.Control.OnClick(EventArgs e)
    at System.Windows.Forms.Button.OnClick(EventArgs e)
    at System.Windows.Forms.Button.WndProc(Message& m)
    at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)

    ************** Loaded Assemblies **************
    mscorlib
    Assembly Version: 4.0.0.0
    Win32 Version: 4.8.3801.0 built by: NET48REL1LAST_B
    CodeBase: file:///C:/Windows/Microsoft.NET/Framework64/v4.0.30319/mscorlib.dll
    —————————————-
    WinaeroTweaker
    Assembly Version: 0.15.0.0
    Win32 Version: 0.15.0.0
    CodeBase: file:///C:/Program%20Files/Winaero%20Tweaker/WinaeroTweaker.exe
    —————————————-
    System
    Assembly Version: 4.0.0.0
    Win32 Version: 4.8.3801.0 built by: NET48REL1LAST_B
    CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_MSIL/System/v4.0_4.0.0.0__b77a5c561934e089/System.dll
    —————————————-
    System.Windows.Forms
    Assembly Version: 4.0.0.0
    Win32 Version: 4.8.3752.0 built by: NET48REL1
    CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_MSIL/System.Windows.Forms/v4.0_4.0.0.0__b77a5c561934e089/System.Windows.Forms.dll
    —————————————-
    System.Drawing
    Assembly Version: 4.0.0.0
    Win32 Version: 4.8.3752.0 built by: NET48REL1
    CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_MSIL/System.Drawing/v4.0_4.0.0.0__b03f5f7f11d50a3a/System.Drawing.dll
    —————————————-
    WinaeroControls
    Assembly Version: 2.0.2.6
    Win32 Version: 2.0.2.6
    CodeBase: file:///C:/Program%20Files/Winaero%20Tweaker/WinaeroControls.DLL
    —————————————-
    System.Configuration
    Assembly Version: 4.0.0.0
    Win32 Version: 4.8.3752.0 built by: NET48REL1
    CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_MSIL/System.Configuration/v4.0_4.0.0.0__b03f5f7f11d50a3a/System.Configuration.dll
    —————————————-
    System.Core
    Assembly Version: 4.0.0.0
    Win32 Version: 4.8.3752.0 built by: NET48REL1
    CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_MSIL/System.Core/v4.0_4.0.0.0__b77a5c561934e089/System.Core.dll
    —————————————-
    System.Xml
    Assembly Version: 4.0.0.0
    Win32 Version: 4.8.3752.0 built by: NET48REL1
    CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_MSIL/System.Xml/v4.0_4.0.0.0__b77a5c561934e089/System.Xml.dll
    —————————————-
    System.Data
    Assembly Version: 4.0.0.0
    Win32 Version: 4.8.3752.0 built by: NET48REL1
    CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_64/System.Data/v4.0_4.0.0.0__b77a5c561934e089/System.Data.dll
    —————————————-
    System.Numerics
    Assembly Version: 4.0.0.0
    Win32 Version: 4.8.3752.0 built by: NET48REL1
    CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_MSIL/System.Numerics/v4.0_4.0.0.0__b77a5c561934e089/System.Numerics.dll
    —————————————-
    System.Xml.Linq
    Assembly Version: 4.0.0.0
    Win32 Version: 4.8.3752.0 built by: NET48REL1
    CodeBase: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_MSIL/System.Xml.Linq/v4.0_4.0.0.0__b77a5c561934e089/System.Xml.Linq.dll
    —————————————-

    ************** JIT Debugging **************
    To enable just-in-time (JIT) debugging, the .config file for this
    application or computer (machine.config) must have the
    jitDebugging value set in the system.windows.forms section.
    The application must also be compiled with debugging
    enabled.

    For example:

    When JIT debugging is enabled, any unhandled exception
    will be sent to the JIT debugger registered on the computer
    rather than be handled by this dialog box.

    Reply
    1. Sergey Tkachenko Post author

      Must be some crappy bug. I will check everything once again. It was working like a charm here.

      Reply
      1. Jimmy Singh

        This error got me twice. It mainly happens when I create a new user account. The fixes from Microsoft didn’t work for me. I’m hoping that you have this fix.

        Reply
    2. tribas

      Happened to my system too this error.

      Reply
  4. Dave

    Ok, so I closed winaerotweaker and reopened it, now if I only select “change startup sound” it throws an error,

    So I closed and reopened it again. I tried the “hide quick access” from the navigation pane. It told me I needed to log off and back on. So I click the yes [to log off] button.

    Now I can’t start my pc even in safe mode. I see the initial windows blue icon, then just a black screen :(

    I used a usb drive to get into the recovery menu but I still just get a black screen.

    Reply
    1. tribas

      I got that black screen too, had to restore the system.

      Reply
  5. Dave

    So, seems a system restore was automatically created before installing WAT 0.15. I was able to use that restore to fix the pc.

    Now I’m afraid to use this newest version.

    Reply
  6. Алексей Долматов

    Thanks.

    Reply
  7. Dave

    Let me know if there’s anything I can do to provide more information. I’ve come to depend on this program to be able to undo all my tweaks before win 10 updates and then import them back after.

    Reply
  8. Shyam Reddy

    Hi Sergey, just noticed, unchecking Compact OS doesnot seem to have any impact. It still appears and on Winaero too it remains checked.

    Reply
    1. Sergey Tkachenko Post author

      Must be also a bug.

      Reply
  9. OMC

    Thank you so much!!!

    Reply
  10. K. K. VinayKumar

    Hi, is there any way to make file explorer light mode if I select custom mode in personalization. That is App mode as dark and task bar and start menu as light. I want file explorer also to be in light mode not in dark mode.

    Reply
  11. Kafar

    Awesome work, as always ! Keep it up. Thanks a lot.

    Reply
  12. Javier Riquel

    A la aplicación para ser completamente útil, le hace falta incluir la característica de desestabilizar las animaciones de Windows al estilo del viejo Tuneap.
    Lo demás excelente!!!!

    Reply
  13. George

    Thank you for your continued, excellent releases! The only problem I’m having is with the import/export feature which still does not work as expected. When I’m importing the exported bookmarks/tweaks, only a very small part of them is imported. If I import the same file again, an additional small part will be imported.

    I have to perform the import process several times to re-import everything, and I’m still not sure it does import everything.

    Reply
    1. Sergey Tkachenko Post author

      Can you name the items which fail to get exported imported? At least a few of them, I will check.

      Reply
      1. George

        My list: https://imgur.com/CzS7ZDg

        I have tweaked all of the above. Tried again a few times now after uninstalling/reinstalling WT. The problem seems to be in the export process, since only the tweaks below are offered in the export window: Scrollbars, Disable MRT, Automatic Folder Type Discovery, Keep Thumbnail Cache, Icon Cache Size, Disable Action Center, Theme Behavior, Remove Default Entries

        Bookmarks now seem to import/export fine, but the actual tweaks do not. This situation is a bit differrent from the one I was used to (tweak AND bookmark import problem, after first installing WT on clean Windows).

        Reply
        1. Sergey Tkachenko Post author

          I will check the export feature today. Maybe it has some bug.

          Reply
          1. Sergey Tkachenko Post author

            Checked. The tweaks you have in bookmarks appear in the export list here without issues. I cannot reproduce the issue.

  14. Dave

    RE: Change Startup Sound

    So, I hit the “how does this tweak work” link and tried to do it manually. I found the “imageres.dll.mun” in c:\windows\systemresources”.

    Everything seemd to go fine until I tried to rename the original file. I can’t. In safe mode I need permission from myself :( /bangheadhere

    Reply
    1. Sergey Tkachenko Post author

      The Tweaker changes the permissions automatically.
      You can do it manually before changing anything.

      Reply
    2. EP

      what version and edition of Win10 are you using, Dave?

      I do not have that imageres.dll.mun file in the c:\windows\systemresources folder, at least it is not there in Win10 LTSC 2019 (v1809). maybe I have to use another edition & version of Win10 to have that file

      Reply
  15. Jeremy El bez

    Hi,

    since windows 1903, “Do this for all current items” checkbox doesn’t work. I check it. Restart my computer and it still uncheck. however look like it’s still on my registry : HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\OperationStatusManager\ConfirmationCheckBoxDoForAll (1)

    Reply
    1. Sergey Tkachenko Post author

      I will look. Thank you.

      Reply
  16. Dave

    You misunderstand. I, Dave, manually took ownership of the file. Then I added my userneme, Dave, with full control to the permission entries.

    Then I restarted in safe mode and logged on with same user, Dave, account.

    It would not let me change the file I, Dave, had both ownership of and full control permissions on saying I needed permission from Dave.

    Reply
    1. Sergey Tkachenko Post author

      Try to perform the same on the folder SystemResources. Do not allow the OS apply the changes recursively.

      Reply
  17. Carlos Martinez

    Dear Sergei Hi,

    Just a simple question,
    what does the “X” in the “XMouse Options” means?

    Thanks in advance for any info,

    Carlos.

    Reply
    1. Sergey Tkachenko Post author

      Extra or Extended. Something like that.

      Reply
  18. BDK

    Woooooo finally able to disable Defender again :) Much appreciated!

    Reply
  19. d0kt0rhaos

    Hello, Sergei,

    First: Congratulations for your excelent work and persistence in the development of Winaero Tweaker – this is one very usefull software!

    And Second: Long time ago with other username I suggested you to add an option to disable automatic folder type discovery and you did it. Thank you about that! Today I want to suggest you to add an option for user to select with witch program edit picture using good old “Edit” button when right click on image file. It’s very annoying to open Paint when there are much better options such as Paint.net and GIMP.
    I don’t wanna be on demanding but helpful too so I have 2 links for you how such option can be implemented:
    http://www.techwork.dk/windows-7/how-to-change-the-default-image-editor-program;
    https://superuser.com/questions/971531/how-to-change-the-default-editor-for-png-files-from-ms-paint-to-paint-net-in-win .

    Good luck and thank you in advance for your time and efforts!

    Reply
    1. Sergey Tkachenko Post author

      Thanks a lot for your valuable suggestions. I will try to add these changes to the tweaker app. Added to my to-do list.

      Reply
  20. Dwedit

    Hello, I have a feature request.
    For the “Boot and Login” section of the program, I’d suggest adding in “Automatic Log-in”, which would run “netplwiz.exe”. It would help people who are aware of tweaking software, but are unaware of the built-in “netplwiz” tool.

    Reply
  21. Dave

    Suggested change.

    With so many options it would be a bit cleaner if items where ‘moved’ to bookmarks instead of ‘copied’, thus elimintaing all the double entires.

    Reply
    1. Sergey Tkachenko Post author

      Hmm, I will consider adding this as an option.

      Reply
  22. Linda Lycett

    Hi
    Where do I find Customize this PC on the new version of Winaero. When I go down to File Explorer and Customize this PC folders, nothing comes up on the window for it, even though there are already folders there.

    It just says Here you can remove folders from this PC and add custom folders, etc. How do I get it to show the current folders, and the buttons so that I can add other folders to it?

    Do I need to change any setting on my computer to make it happen?

    Thanks
    Linda

    Reply
    1. Zarko

      Do you see the lil “Folders(n)” writing at the top of the folder area (switch to Details)? And a lil triangle left of it ? Click it :-) I keep it closed all the time – to the point that I don’t even remember that there’s anything there at all. I wonder if it’ going to vanish if I kill them all :-))) YUP – it worked :-) The “Folders” bugger is gone.

      OK now I want actual location (physical or REG) and a script to run to kill them all on a new install – hate these buggers :-)

      Oh and if you change something you have to close and reopen a File Explorer window – it’s not hot-updated.

      Reply
  23. Zarko

    I just stumbled on something that I thought was WinAero’s fault/bug (maybe it still is – too chicken to check on LTSB :-) but now on 18362.418 I can see parts of it’s “genesis” so I’m going to dump in here what I know (don’t publish it’s TL;DR :-).

    The problem is that Inactive Title Bar Color get’s “garbled” – like with a shade of gray, which makes text in inactive File Explorer windows almost unreadable. It happens when you switch to Aero Lite theme and there’s no going back (“restore” default theme doesn’t clear that).

    BUT – in Colors (Settings/Personalization/Color) I now saw 2 “recent colors” – one named “Blue” (a variant of light blue) and the other named “Storm” – that one might have been that nasty noisy gray that I remember from LTSB — the color in the title bar that Aero Lite makes seems to be the “fusion” and these 2 – could also be that that Aero dll is generating “grain” which maybe works as alpha channel on Win 7 (pure guess here) ?

    Little proof: pick that “Blue” as accent color, then check “automatically pick” (you’ve got a dark color in title bar which looks like these 2 combined), now uncheck “automatically pick” — the “Blue” is back to checked state but that didn’t reflect on the title bar ! Now pick another color, say Violet — it’s in the title bar now, back to “Blue” – reflected, but that dark part is gone.

    Part 2: Inactive Title bar Color (set from Winaero) doesn’t get reflected to (akka applied, used – these 2 word imply the mechanism: applied == gets copied, used == is always referenced form orig. loc.) title bars at all – except for Chrome :-) Chrome hijacks the whole windows drawing (which has negative consequences elsewhere – the infamous not-respecting UI fonts and sizes that Win manages for all exe-s) and it does reflect the changed color immediately => in this case Chrome ends up being more responsive – Win .

    That part (inactive color “propagation”) seems to settle after logout or reboot (can’t check now – for obvious reasons :-). Out of desperation I left it as screaming yellow yesterday, applied a few other tweaks which did require signout other we, laptop went to hibernation, when it continued (icon spacing and font size), closed the lid (== hibernate) and went to sleep. Wasn’t checking that state of “inactive” so i can’t say decisively when it “happened”. When I opened it today it was “working”.

    Now, while writing this I did “set default theme” and then back to Aero Lite (no logouts, obviously) and went to hibernation and back — no effect — OK HALF EFFECT :-) The nasty dark tone in inactive was gone but that’s Setting’s doing. There is an article on the net with the steps you have to go in order to have separate inactive color set and respected – forgot the steps but I think it includes one one two reboots.

    On LTSB the “inactive” never went back to “clear, one color” – I reinstalled the OS eventually and haven’t touched Winaero at all – safe is safe :-) and that’s my main “box”.

    All in all it looks like either a dll remains “connected” (it it has something active – not just “resources”) or there’s another registry location (or 2) that effects inactive bar rendering.

    Semi-related – the color of text in a title bar – switching the color “dictates” the font color of black or white => there might be another location regulating this or a flag with each color. Would be good to control that – this new “Blue” looks like it could work with white as well – the dark combo from Aero lite was “setting” white, but when you turn off “auto pick” it goes back to black == unreadable till you force the color switch.

    Bigger problem whit that is that inactive title bar seems to always get some gray which makes it unreadable in most cases – right now for example that that new “blue” is still reigning over inactive. So this would have to be a 2nd flag or even a location with the full color code/number.

    BTW I’m playing how with this laptop that I’ll have to return tomorrow so if you need me to try or “excavate” anything shoot me an e-mail but you have to be fast – I’m at -9 (PST) and you are probably +2 (although the net said 5:30 in Moscow, 19:30 here => +10 => one of us is not in “shifted time” anymore – there is a US-Europe gap once or twice a year). Visual Studio is on it (15 and 17). Don’t have a kd cable, haven’t tried if it might work with plain USB these days and no time to try now.

    Reply
    1. Zarko

      Part 3: Still on the inactive bar “case” – did signout, went into reboot – still no change.

      Title bar color to violet and back to the “new Blue” (at least it changes color on all bars – I use it as a checkup that “something gets propagated”, to clean up Aero Lite leftover, and as a mini-reset “action”).

      Then, in Winaero, I changed “something” (wasn’t really paying attention – didn’t expect anything major to happen) that forced or triggered Win to go into what I call “UI change screen” (monocolor background and text “Please Wait”, used to be b/w on Win 7 and most changes in UI triggered it – there was also a kind of “apply” button to trigger it manually).

      After that, inactice color was “connected” – changes in Winaero get reflected immediately.

      So – need a way (and a distinctive button) to force Windows to go into that procedure – hopefully without having to change anything real or doing some miniscule change to “convince it” that “yes it needs to” :-)

      That process is apparently “stronger” than “signout” so chances are that if you can make Win enter it deterministically, on command, the “signout” may become unnecessary. It is lighter in a sense that it doesn’t close your exe-s.

      Hopefully by the time I need to run Winaero for real on a box you’ll have the next version with “that” :-)

      Now if only I could force/control that inactive text “gray” (if it’s even a real gray) :-) at least to be able to change/force color into it (then I can put in say inverse of the title bar color – that should be always readable).

      Reply
  24. Zarko

    On the UAC matters. Look at the 1st answer on this page:

    https://superuser.com/questions/1022273/separate-custom-scaling-levels-for-each-display-in-windows-10

    You need to treat these policies as a package. That also means that if you are touching the REG it has to be at the exact paths the gpedit uses – otherwise you’ll lave a mess and lose control.

    The 1st one:
    User Account Control: Admin Approval Mode for the Built-in Administrator account Disabled

    decides whether Meto apps are going to refuse to run. Disabled is fine on LTSB and Server (2016, 2019 – 2019 is the champ BTW – much more responsive, more or less devved to for a workstation use)

    But, if you turn it on, you have to put the “Elevate without prompting” in and disable “secure desktop” or it’s still going to bug you.

    The sole caveat leftover is that occasionally you will still have to do “Run As Admin” since exe-s are not auto-elevated and those that don’t ask for elevation will now work “magically” (you just turned off all prompting => those that don’t ask are silently denied).

    The sole solution for that is LTSB of Server SKU.

    Reply
  25. Byron K

    Here lately Windows 10 has tried to force feed me 1903, even though I have this program installed and the option to keep Windows 10 from updating is checked. Has MicroThief found a way past this program?

    Reply
  26. George

    Safe to use 0.15 with 1909 or best to wait for a Winaero Tweaker update?

    Reply
    1. Sergey Tkachenko Post author

      It actually works without issues there.

      Reply
      1. George

        Thank you Sergey, and thanks for 0.16 :)

        Reply

Leave a Reply

Your email address will not be published. Required fields are marked *